Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

This change prevents confusion between the RestoreRedundancyRegionResult and RestoreRedundancyResults classes.


The RestoreRedundancyResults interface should now be:

public interface RestoreRedundancyResults {
  enum Status {
    SUCCESS,
    FAILURE,
    ERROR
  }

  void addRegionResults(RestoreRedundancyResults results);

  void addRebalanceInfoDetails(PartitionRebalanceInfo details);

  void addRegionResult(RestoreRedundancyRegionResult regionResult);

  Status getStatus();

  String getMessage();

  RestoreRedundancyRegionResult getRegionResult(String regionName);

  Map<String, RestoreRedundancyRegionResult> getZeroRedundancyRegionResults();

  Map<String, RestoreRedundancyRegionResult> getUnderRedundancyRegionResults();

  Map<String, RestoreRedundancyRegionResult> getSatisfiedRedundancyRegionResults();

  Map<String, RestoreRedundancyRegionResult> getRegionResults();

  int getTotalPrimaryTransfersCompleted();

  long getTotalPrimaryTransferTime();

  int getNumberOfMembersExecutedOn();

}

The new method makes use of the new information on how many members actually executed the operation introduced in 

Jira
serverASF JIRA
serverId5aa69414-a9e9-3523-82ec-879b028fb15b
keyGEODE-7838
, which had not been merged at the original time of writing the RFC. The method name change reflects the new, broader set of information that will be obtained from the PartitionRebalanceInfo object passed as its argument.

References

Anchor
ref1
ref1
[1] https://issues.apache.org/jira/projects/GEODE/issues/GEODE-4250 

...