Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

[dmitriy setrakyan]: I am not sure I see the reason for removing the word classLoader on serialization part and keeping it on deserialization. I also think that the method names should be symmetric. With that in mind, "encodeClassLoader" and "decodeClassLoader" may not be the best names, but they are consistent with each other and symmetric. My vote would be to keep the naming.

[romain.gilles]: I agree with the fact that we are not serializing the classLoader but I think the new name is too generic. Here we focus on how to resolve ClassLoader. I like the single responsibility principle therefore I think the name should relate the scoped responsibility which is resolving the classLoader. DeserialisationHintsCodec does not express this point in my opinion. ClassLoaderHintsCodec is a mix of the 2 proposals. And maybe, In order to keep the symmetry between the method name (I'm agree with Dmitriy on this point) we may give the following name to the methods encodeHints(...) and decodeHints(...).

ClassLoaderCodec

The ClassLoaderCodec should be called for every Object during serialization and deserialization and should be part of the IgniteConfiguraiton:

...