Document the state by adding a label to the FLIP page with one of "discussion", "accepted", "released", "rejected".

Please keep the discussion on the mailing list rather than commenting on the wiki (wiki discussions get unwieldy fast).

Motivation

The MetricGroup interface contains methods to create groups and metrics using an int as a name. The original intention was to allow pattern like group.addGroup("subtaskIndex").addGroup(0) , but this didn't really work out, with addGroup(String, String)  serving this use-case much better.

Metric methods accept an int mostly for consistency, but there's no good use-case for it.

These methods also offer hardly any convenience since all they do is save potential users from using String.valueOf on one argument. That's doesn't seem valuable enough for something that doubles the size of the interface.

Public Interfaces

MetricGroup methods:

  • #counter(int[, Counter])
  • #meter(int, Meter)
  • #gauge(int, Gauge)
  • #histogram(int, Histogram)
  • #addGroup(int)

Proposed Changes

Remove the methods without a replacement.

Compatibility, Deprecation, and Migration Plan

  • What impact (if any) will there be on existing users?
  • Users that rely on these methods will have to migrate to the String-based variants. This migration shouldn't be difficult.
  • As the MetricGroup interface is part of the public API we will deprecate the methods 2 releases before removal.